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Macros
Lesson Plan

A student with intermediate Excel skills learns how to apply repetitive changes using macros to an Excel workbook.

Lesson Objectives
At the end of the class, the student will:
· Understand what a macro is and what it does.
· Know how to record a macro.
· Know how to change a macro to a relative reference.
· Know how open a macro in VBA editing mode.

Lesson Prep Work
(30 min, at a minimum, prior to student arrival)
· get in early to test for technology failure, because it will happen :-)
· pre-save Macros.xlsx to the desktop of each computer.
· print handouts

Lesson Prerequisites
· Microsoft Excel Basics plus practice time
· Microsoft Excel: Formulas and Functions plus practice time

Lesson Outline
The lesson is completed in one (60) minute class session.
(5) Introduction
· Introduce instructor, students.
· Ask students at introduction: What have you already heard about Macros?
· Let students know it’s okay to take phone calls, but ask them to put their phone on vibrate and answer calls outside the classroom.
· Inform students that they can sit back and watch if the class is too advanced.
· Inform students they can go to the bathroom, they don’t need permission.
· Show order in which class will happen. Explain scope of class.



(5) Vocabulary
· Open Macro.xlsx from the desktop.
· Ribbon and Tabs
· Home Tab – where your most frequently accessed features are.
· View Tab – where you can organize how a page prints and record macros.
· Workbook and Worksheet
· Workbook - made up of one or more worksheets. It is the actual file.
· Worksheet – individual sheets in workbook. Accessed through the tabs at the bottom of the workbook.
· Ask students: “What is a macro?”
· A macro is a series of recorded actions that you can then apply to other locations.
· Think about hot key combinations. They are shortcuts to make your job easier and you faster at using the computer. 
· Ask students to list the hot key combinations they already know and what they do.
· Hot keys are shortcuts for actions you would otherwise do by clicking a button.
· Macros function in the same way: you run a key combination to perform a series of actions you would otherwise do by clicking buttons.
· Why would you use a macro?
· If you need to apply the same changes to a series of workbooks or in different places within a single workbook.
· Using a computer means you shouldn’t have to repeat yourself. If you’re doing to same task over and over, think about trying to use a macro.
· Activity: Demo the purpose of a macro before class.
· I have a stack of pencils here. I need to move them all to that table over there. I am only allowed to move one pencil at a time.
· Now, if I do this action once and record it, then all the rest of the pencils are moved automatically without me having to commit any more effort.
· Activity: Demo a macro set up before class.
· Pre-record on another version of the workbook you are using in class to demo the potential of Excel.
· My recommendations are to create a stats database.
· Yearly averages earned by each store
· Average Monthly earnings
· Basic formatting to make the stats look more appealing.
· Mention to students that we are working with Macros in Excel today, but they work the exact same way in Word & PowerPoint and many other applications.

(10) Record a Basic Macro
· Explanation
· We want to start by recording a macro that will apply several formatting changes to the worksheets we are working with.
· In this case, we want to:
· Merge Cells A1 – D1 and make the text size 26
· Make columns A – D fit all of their text
· Make all of our number values show up as Currency
· Make the months and store names have a green background and white text
· Make the number values have a grey background with white text
· We want to apply this to several worksheets, so we are going to record a macro on the first one, and use the macro to apply the same template to the other worksheets.
· Activity: Setup the macro you are going to record.
· Step 1 – Open the 2011 worksheet.
· Step 2 - Click on the Macros arrow on the View tab.
· Teacher’s Tip: Point out that the Macros button is actually two different buttons. If you click on the image, it will take you to a list of all previously recorded macros.
· Step 3 – Click on Record Macro.
· Step 4 – Name the macro, for this class, we will call it FormattingChanges.
· Point out that you cannot leave spaces between the words in macro names.
· Step 5 – Set a shortcut key.
· We’ve already discussed hotkeys; this is the hotkey to run this macro.
· When you assign a shortcut for your Macro, make sure not to use a combination you use for something else. If you make the macro CTRL + c, you lose the shortcut for copy and will probably end up accidentally running the macro at some point.
· For the sake of this class, we are going to use CTRL + q.
· Step 6 – Give the macro a description for people accessing it in the future. In this case, record the changes we are going to make to our workbook (e.g. Merge cells…)
· Step 7 – Click on OK.
· Teacher’s Tip: it is useful to caution students before clicking on OK not to click on anything unnecessarily. The macro will record our every movement, if we make a change, it will be part of the macro. 
· Step 8 – Record the macro.
· Merge Cells A1 – D1 and make the text size 26
· Make columns A – D fit all of their text
· Make all of our number values show up as Currency
· Make the months and store names have a green background and white text
· Make the number values have a grey background with white text
· Step 9 – Click on Macros on the View tab.
· Step 10 – Click on Stop Recording.

(5) Run the Macro on Another Worksheet
· Explanation
· Now that we’ve recorded the macro, we can run it on any worksheet we want.
· Before we begin, when you run a macro, it becomes permanent in the workbook. There is no undo. 
· The only way to fix something a macro screwed up is by hand. 
· I would recommend always saving a copy of the workbook to test your macro before you run it just to make sure you don’t mess up your data.
· Activity: Save a copy of the workbook.
· Step 1 – Click on the Office Button.
· Step 2 – Click on Save As…
· Step 3 – Click on the Save as Type menu.
· Step 4 – Click on Excel Macro-Enabled Workbook.
· Step 5 – Click on Desktop in the left hand navigation pane.
· Step 6 - Click on Save.
· Activity: Run the macro on another worksheet.
· Step 1 – Open the 2012 worksheet.
· Step 2 – Type in CTRL + q to run the macro.
· Teacher’s Tip: remind students that this is the shortcut key we assigned to the macro before we recorded it.
· Step 3 – Open the 2013 worksheet.
· Step 4 – Type in CTRL + q to run the macro.
· Point out that the macro applied the formatting to the same cells as the other worksheets, not to the cells we would like them to have adjusted. We will address this later when we talk about absolute v. relative references. 
· Press CTRL + Z to undo. Psych! You cannot undo the actions of a macro.
· Step 5 – Select the range of cells from A7 – D19.
· Step 6 – Drag the cells up to cell A4.
· Step 7 – Run the macro again by pressing CTRL + q.

(15) Absolute v. Relative References
· Explanation
· The default when you record a macro is to run as an absolute reference. 
· Back to our pencil example earlier. If I need to move the pencil from this EXACT location to that EXACT location, a basic macro is fine. But, if I walk into another room and the tables are moved 3 feet to the left, the macro would be flummoxed.
· If instead, I tell the macro that any pencils I pick up from any table need to be moved two tables over and one table back, we can tell the macro where to start looking for pencils.
· So, when you select cell A1, Excel sees cell A1. When you run the macro, it will apply whatever changes you made in cell A1 to cell A1, no matter what cell you have selected.
· If you change your macro to record as a relative reference, when you click in cell A1 and make your changes the macro records what the changes are, not the cell address. Then, if you click in cell D3, when you run the macro, those changes are applied to D3 (or whatever cell you have selected).
· The same thing will apply to ranges of cells. By default, if you select A1 – D3, Excel will apply the macro to A1 – D3 on every worksheet you run the macro on. If you set it for relative references, you can record the macro in A1 – D3, but apply the macro to A4 – D6.
· For more on absolute v. relative references, go to the Formulas and Functions class.
· Activity: Record a relative reference macro.
· Step 1 – Go back to the 2011 worksheet.
· Step 2 – Click into cell A17.
· Step 3 - Click on Macros on the View tab.
· Step 4 – Click on Use Relative References.
· Step 5 – Click on Macros on the View tab.
· Step 6 – Click on Start Recording.
· Step 7 – Fill in the dialog box. Call the macro StatsReporting, and use CTRL + M for the shortcut key.
· Step 8 – Type in “Total”.
· Step 9 – Insert an AutoSum in B17 and autofill across to D17. 
· Step 10 – Type “Average” in A18.
· Step 11 – Insert the Average function in cell B18 for cells B5:B16 and autofill across.
· Step 12 – Click on Macros on the View tab.
· Step 13 – Click on Stop Recording.
· Activity: Run the macro on another worksheet.
· Step 1 – Open the 2012 worksheet. 
· Step 2 – Click on cell B17.
· Because we recorded this using relative references, we need to click in the cell we want our Autosum (the first action of our macro) to appear in BEFORE we run the macro.
· Step 3 – Type CTRL + M.
· What happens when we click in the wrong cell before running our macro?
· Step 4 – Open the 2013 worksheet. 
· Step 5 – Click in cell B15 (the wrong starting cell).
· Step 6 – Type in CTRL + M.
· Point out that the formulas turn out wrong. This is because the macro was started from cell B15 instead of B17.
· Point out that to correct the errors that were made with this macro, you have to fix everything by hand. We can’t just undo. 
· Remind students that this is why we always save a copy of our work and test new macros on copies instead.
· Step 7 – Open the 2014 worksheet.
· Step 8 – Click in cell B20.
· Step 9 – Type in CTRL + M.
· Point out that even though the sheet was not set up the same, the macro did what it was supposed to.
· Because relative references! It performed the functions we asked it to relative to the cell we started running the macro in.

(5) Edit a Macro
· Explanation
· For simple edits, you can edit a macro in VBA.
· If you need to make a bunch of changes to your macro, it is easiest to delete it and re-record it.
· In this case, our supervisor wants us to change the macro so the font size is 18 instead of 26.
· Activity: Edit the FormattingChanges macro.
· Step 1 – Click on Macros on the View tab.
· Step 2 – Click on View Macros.
· Step 3 – Click on the FormattingChanges macro.
· Step 4 – Click on Edit.
· The interface that opens is VBA. You can learn to code VBA if you choose to do so. Look for tutorials on support.microsoft.com.
· Step 5 – Find the line for font size and change the value to 18.
· Step 6 – Click Save to save the changes.
· Step 7 – Close out of the VBA interface.
· Changing the macro doesn’t apply any changes to the workbook.
· Step 8 – Type CTRL + q to rerun the macro.
· Comprehension Check: Delete the StatsReporting macro.
· Step 1 – Click on Macros on the View tab.
· Step 2 – Click on View Macros.
· Step 3 – Click on StatsReporting.
· Step 4 – Click on Delete.

(5) Opening a Macro-Enabled Workbook
· Explanation
· You can find macros created by other people online.
· Beware of downloading macros from the internet. They can and have been used to put malicious software onto unsuspecting computers. 
· Make sure you only download macros from reputable sources. 
· Office. Microsoft.com
· IT people in the office you work in.
· Because macros can be dangerous, when you save a workbook as a macro-enabled workbook, you have to enable macros to run them the next time you open it.
· Activity: Open and enable macros in the workbook.
· Step 1 – Save the workbook by clicking the save icon and close out of it.
· Point out that the macro-enabled workbook icon has an exclamation point over it. This just indicates the type of workbook it is.
· Step 2 - Double click on the saved workbook.
· Step 3 – Click on the Options… button in the security warning at the top.
· Step 4 – Click on Enable this content.
· Step 5 – Click on OK. 
· Teacher’s Tip: it can help to start a new sheet and show that CTRL + q doesn’t change the document. Once you enable macros, type CTRL + q and show all the formatting changes that happen to the sheet.

(5) Help
· Use the Help Button to look for instructions for macros. 
· Perform a Google video search for macros.
· Find basic help at gcflearnfree.org. 


(5) Conclusion 
· Go over handout, review material, and emphasize contact info & further resources on handout.
· Any questions? Final comments?
· Remind patrons to practice; assign take-home-practice - remind them they can ask for help
· Remind to take survey.


Appendix
What This Lesson Does Not Cover
· We do not go into VBA coding. This class is designed to be an introduction to Macros and some of the basic features of Macros in Excel. VBA is beyond the level of our average student.
· We do not cover Trust Center settings. This is a little too advanced for our average student and a little too dangerous. Many of them wouldn’t understand exactly what they were working with.

Key Decisions
1. We decided to use the Macros button on the View tab instead of turning on the Developer tab. While the Developer tab allows direct access to the VBA interface, we aren’t really covering that in depth. 
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